#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0\d)\d{1,3}(?:\.\d{3})*,\d{2}$"
Local $sString = "1.123,45" & @CRLF & _
"1,23" & @CRLF & _
"1.234.567,45" & @CRLF & _
"0,56" & @CRLF & _
"0,00" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"12" & @CRLF & _
"01,56" & @CRLF & _
"1,5" & @CRLF & _
"01,100.36" & @CRLF & _
"1,1236.25"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")