use strict;
my $str = '1.123,45
1,23
1.234.567,45
0,56
0,00
12
01,56
1,5
01,100.36
1,1236.25';
my $regex = qr/^(?!0\d)\d{1,3}(?:\.\d{3})*,\d{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}