re = /^(?!0\d)\d{1,3}(?:\.\d{3})*,\d{2}$/m
str = '1.123,45
1,23
1.234.567,45
0,56
0,00
12
01,56
1,5
01,100.36
1,1236.25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end