using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0\d)\d{1,3}(?:\.\d{3})*,\d{2}$";
string input = @"1.123,45
1,23
1.234.567,45
0,56
0,00
12
01,56
1,5
01,100.36
1,1236.25";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}