const regex = /^(?!0\d)\d{1,3}(?:\.\d{3})*,\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0\\d)\\d{1,3}(?:\\.\\d{3})*,\\d{2}$', 'gm')
const str = `1.123,45
1,23
1.234.567,45
0,56
0,00
12
01,56
1,5
01,100.36
1,1236.25`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}