# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\d{1,2}(?:\D+\d{1,2})?\D+(?:year|month)s?\b//gm;t' <<< " I have total exp of 10-11 years. This includes 15 years in SAS and 5 years in python. I also have 8 months of exp in R programming."