use strict;
my $str = ' I have total exp of 10-11 years. This includes 15 years in SAS and 5 years in python. I also have 8 months of exp in R programming.';
my $regex = qr/\b\d{1,2}(?:\D+\d{1,2})?\D+(?:year|month)s?\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";