re = /\b\d{1,2}(?:\D+\d{1,2})?\D+(?:year|month)s?\b/m
str = ' I have total exp of 10-11 years. This includes 15 years in SAS and 5 years in python. I also have 8 months of exp in R programming.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result