const regex = new RegExp('\\b\\d{1,2}(?:\\D+\\d{1,2})?\\D+(?:year|month)s?\\b', 'gm')
const str = ` I have total exp of 10-11 years. This includes 15 years in SAS and 5 years in python. I also have 8 months of exp in R programming.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);