$re = '/\b\d{1,2}(?:\D+\d{1,2})?\D+(?:year|month)s?\b/m';
$str = ' I have total exp of 10-11 years. This includes 15 years in SAS and 5 years in python. I also have 8 months of exp in R programming.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;