#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\brefuse\b)I require\b[\w\s]*\bto disclose the information\.$"
Local $sString = "I require the creepy caterpillar to disclose the information." & @CRLF & _
"I require the giant bug to refuse to disclose theinformation." & @CRLF & _
"I require the dusty moth to disclose the information." & @CRLF & _
"You must not refuse." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")