import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\brefuse\\b)I require\\b[\\w\\s]*\\bto disclose the information\\.$";
final String string = "I require the creepy caterpillar to disclose the information.\n"
+ "I require the giant bug to refuse to disclose theinformation.\n"
+ "I require the dusty moth to disclose the information.\n"
+ "You must not refuse.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}