const regex = /^(?!.*\brefuse\b)I require\b[\w\s]*\bto disclose the information\.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\brefuse\\b)I require\\b[\\w\\s]*\\bto disclose the information\\.$', 'gm')
const str = `I require the creepy caterpillar to disclose the information.
I require the giant bug to refuse to disclose theinformation.
I require the dusty moth to disclose the information.
You must not refuse.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}