re = /^(?!.*\brefuse\b)I require\b[\w\s]*\bto disclose the information\.$/m
str = 'I require the creepy caterpillar to disclose the information.
I require the giant bug to refuse to disclose theinformation.
I require the dusty moth to disclose the information.
You must not refuse.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end