using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\brefuse\b)I require\b[\w\s]*\bto disclose the information\.$";
string input = @"I require the creepy caterpillar to disclose the information.
I require the giant bug to refuse to disclose theinformation.
I require the dusty moth to disclose the information.
You must not refuse.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}