#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=.*(?=\w.*yes)(?=\w.*or)(?=\w.*yes)).*"
Local $sString = "yes or yes" & @CRLF & _
"no or yes" & @CRLF & _
"yes or no" & @CRLF & _
"maybe yes or yes" & @CRLF & _
"yes maybe or yes" & @CRLF & _
"maybe yes maybe yes maybe or"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")