const regex = /^(?=.*(?=\w.*yes)(?=\w.*or)(?=\w.*yes)).*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*(?=\\w.*yes)(?=\\w.*or)(?=\\w.*yes)).*', 'gmi')
const str = `yes or yes
no or yes
yes or no
maybe yes or yes
yes maybe or yes
maybe yes maybe yes maybe or`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}