import re
regex = re.compile(r"^(?=.*(?=\w.*yes)(?=\w.*or)(?=\w.*yes)).*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("yes or yes\n"
"no or yes\n"
"yes or no\n"
"maybe yes or yes\n"
"yes maybe or yes\n"
"maybe yes maybe yes maybe or")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")