$re = '/^(?=.*(?=\w.*yes)(?=\w.*or)(?=\w.*yes)).*/mi';
$str = 'yes or yes
no or yes
yes or no
maybe yes or yes
yes maybe or yes
maybe yes maybe yes maybe or';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);