re = /^(?=.*(?=\w.*yes)(?=\w.*or)(?=\w.*yes)).*/mi
str = 'yes or yes
no or yes
yes or no
maybe yes or yes
yes maybe or yes
maybe yes maybe yes maybe or'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end