$re = '/\D*(\d+)\D+(\d+)\D+(\d+)\D*/s';
$str = '81cm:36cm:50cm
60L:30l:30h
12@#[]{}!($£ :34%_+=/;:56?,.\'azerrtyuuioQSDFFGHJK
80-80-40
60+60+80
38 x 38 x 43
et même des trucs avant 60L : 30l: 30H et plein de trucs après;';
$subst = "$1:$2:$3\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;