import re
regex = re.compile(r"\D*(\d+)\D+(\d+)\D+(\d+)\D*", flags=re.DOTALL)
test_str = ("81cm:36cm:50cm\n"
"60L:30l:30h\n"
"12@#[]{}!($£ :34%_+=/;:56?,.'azerrtyuuioQSDFFGHJK\n"
"80-80-40\n"
"60+60+80\n"
"38 x 38 x 43\n"
"et même des trucs avant 60L : 30l: 30H et plein de trucs après;")
subst = "$1:$2:$3\\n"
result = regex.sub(subst, test_str)
if result:
print(result)