// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\D*(\d+)\D+(\d+)\D+(\d+)\D*").unwrap();
let string = "81cm:36cm:50cm
60L:30l:30h
12@#[]{}!($£ :34%_+=/;:56?,.'azerrtyuuioQSDFFGHJK
80-80-40
60+60+80
38 x 38 x 43
et même des trucs avant 60L : 30l: 30H et plein de trucs après;";
let substitution = "$1:$2:$3\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}