import Foundation
let pattern = #"\D*(\d+)\D+(\d+)\D+(\d+)\D*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
81cm:36cm:50cm
60L:30l:30h
12@#[]{}!($£ :34%_+=/;:56?,.'azerrtyuuioQSDFFGHJK
80-80-40
60+60+80
38 x 38 x 43
et même des trucs avant 60L : 30l: 30H et plein de trucs après;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:$2:$3\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)