package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+>\s*(.+)<\/.+>`)
var str = `<div><span>text text</span></div><a href="#">link</a>
<div><input type="button" value="click"><ul><li>item1</li><li>item2</li></ul></div>
<p><pos w="12">good</pos></p>
text<a href="#">text link</a>
<button>name</button><textarea></textarea>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}