import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+>\\s*(.+)<\\/.+>";
final String string = "<div><span>text text</span></div><a href=\"#\">link</a>\n"
+ "<div><input type=\"button\" value=\"click\"><ul><li>item1</li><li>item2</li></ul></div>\n"
+ "<p><pos w=\"12\">good</pos></p>\n"
+ "text<a href=\"#\">text link</a>\n"
+ "<button>name</button><textarea></textarea>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}