import Foundation
let pattern = #".+>\s*(.+)<\/.+>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<div><span>text text</span></div><a href="#">link</a>
<div><input type="button" value="click"><ul><li>item1</li><li>item2</li></ul></div>
<p><pos w="12">good</pos></p>
text<a href="#">text link</a>
<button>name</button><textarea></textarea>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)