// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".+>\s*(.+)<\/.+>").unwrap();
let string = "<div><span>text text</span></div><a href=\"#\">link</a>
<div><input type=\"button\" value=\"click\"><ul><li>item1</li><li>item2</li></ul></div>
<p><pos w=\"12\">good</pos></p>
text<a href=\"#\">text link</a>
<button>name</button><textarea></textarea>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}