use strict;
my $str = '<div><span>text text</span></div><a href="#">link</a>
<div><input type="button" value="click"><ul><li>item1</li><li>item2</li></ul></div>
<p><pos w="12">good</pos></p>
text<a href="#">text link</a>
<button>name</button><textarea></textarea>
';
my $regex = qr/.+>\s*(.+)<\/.+>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}