# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G(?!\A)
(?: [^\[]+ | (?! \[\/?quote). )*+ \K
(
\[quote[^\]]*\]
(?: [^\[]+ | (?!\[\/?quote). | (?1) )*+
\[\/quote\]
)
| \[quote[^\]]*\] \K//gix;t' <<< "
[quote]lol [quote=2][quote=3] a[/quote]b[/quote]c[/quote]
[quote] a [quote=bob]a[/quote] text [quote][quote]a[/quote]b[/quote]c[/quote]
"