use strict;
my $str = '
[quote]lol [quote=2][quote=3] a[/quote]b[/quote]c[/quote]
[quote] a [quote=bob]a[/quote] text [quote][quote]a[/quote]b[/quote]c[/quote]
';
my $regex = qr~\G(?!\A)
(?: [^\[]+ | (?! \[/?quote). )*+ \K
(
\[quote[^\]]*\]
(?: [^\[]+ | (?!\[/?quote). | (?1) )*+
\[/quote\]
)
| \[quote[^\]]*\] \K~ixp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";