re = /\G(?!\A)
(?: [^\[]+ | (?! \[\/?quote). )*+ \K
(
\[quote[^\]]*\]
(?: [^\[]+ | (?!\[\/?quote). | (?1) )*+
\[\/quote\]
)
| \[quote[^\]]*\] \K/ix
str = '
[quote]lol [quote=2][quote=3] a[/quote]b[/quote]c[/quote]
[quote] a [quote=bob]a[/quote] text [quote][quote]a[/quote]b[/quote]c[/quote]
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result