using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G(?!\A)
(?: [^\[]+ | (?! \[/?quote). )*+ \K
(
\[quote[^\]]*\]
(?: [^\[]+ | (?!\[/?quote). | (?1) )*+
\[/quote\]
)
| \[quote[^\]]*\] \K";
string substitution = @"";
string input = @"
[quote]lol [quote=2][quote=3] a[/quote]b[/quote]c[/quote]
[quote] a [quote=bob]a[/quote] text [quote][quote]a[/quote]b[/quote]c[/quote]
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}