#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^ \\])\$0([^ \\])"
Local $sString = "Hello '$0'. '$0' becomes the World. \$0 This shall remain \$0" & @CRLF & _
"Hello "$0". "$0" becomes the World. \$0 This shall remain \$0" & @CRLF & _
"Hello [$0]. [$0] becomes the World. \$0 This shall remain \$0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")