using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^ \\])\$0([^ \\])";
string input = @"Hello '$0'. '$0' becomes the World. \$0 This shall remain \$0
Hello ""$0"". ""$0"" becomes the World. \$0 This shall remain \$0
Hello [$0]. [$0] becomes the World. \$0 This shall remain \$0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}