re = /([^ \\])\$0([^ \\])/m
str = 'Hello \'$0\'. \'$0\' becomes the World. \\$0 This shall remain \\$0
Hello "$0". "$0" becomes the World. \\$0 This shall remain \\$0
Hello [$0]. [$0] becomes the World. \\$0 This shall remain \\$0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end