#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=vol": ').*(?=',\s*"tvr)"
Local $sString = "M18.r_16981 = {" & @CRLF & _
" "ltt": '2018/06/21 11:43'," & @CRLF & _
" "np": '0.050'," & @CRLF & _
" "iep": '0.000'," & @CRLF & _
" "iev": '0'," & @CRLF & _
" "ltp": '0.050'," & @CRLF & _
" "vol": '940000'," & @CRLF & _
" "tvr": '49860'," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" "dyh": '0.060'," & @CRLF & _
" "dyl": '0.049'" & @CRLF & _
"};"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")