import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=vol\": ').*(?=',\\s*\"tvr)";
final String string = "M18.r_16981 = {\n"
+ " \"ltt\": '2018/06/21 11:43',\n"
+ " \"np\": '0.050',\n"
+ " \"iep\": '0.000',\n"
+ " \"iev\": '0',\n"
+ " \"ltp\": '0.050',\n"
+ " \"vol\": '940000',\n"
+ " \"tvr\": '49860',\n\n\n\n"
+ " \"dyh\": '0.060',\n"
+ " \"dyl\": '0.049'\n"
+ "};";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}