re = /(?<=vol": ').*(?=',\s*"tvr)/m
str = 'M18.r_16981 = {
"ltt": \'2018/06/21 11:43\',
"np": \'0.050\',
"iep": \'0.000\',
"iev": \'0\',
"ltp": \'0.050\',
"vol": \'940000\',
"tvr": \'49860\',
"dyh": \'0.060\',
"dyl": \'0.049\'
};'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end