use strict;
my $str = 'M18.r_16981 = {
"ltt": \'2018/06/21 11:43\',
"np": \'0.050\',
"iep": \'0.000\',
"iev": \'0\',
"ltp": \'0.050\',
"vol": \'940000\',
"tvr": \'49860\',
"dyh": \'0.060\',
"dyl": \'0.049\'
};';
my $regex = qr/(?<=vol": ').*(?=',\s*"tvr)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}