import re
regex = re.compile(r"(?<=vol\": ').*(?=',\s*\"tvr)", flags=re.MULTILINE)
test_str = ("M18.r_16981 = {\n"
" \"ltt\": '2018/06/21 11:43',\n"
" \"np\": '0.050',\n"
" \"iep\": '0.000',\n"
" \"iev\": '0',\n"
" \"ltp\": '0.050',\n"
" \"vol\": '940000',\n"
" \"tvr\": '49860',\n\n\n\n"
" \"dyh\": '0.060',\n"
" \"dyl\": '0.049'\n"
"};")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")