#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=(?!1ST\b)\d)(?=[^\d\s])|(?<=[^\d\s])(?=(?!1ST\b)\d)"
Local $sString = "1ST DEF 100CD" & @CRLF & _
"ABC 1ST 100CD"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)