re = /(?<=(?!1ST\b)\d)(?=[^\d\s])|(?<=[^\d\s])(?=(?!1ST\b)\d)/m
str = '1ST DEF 100CD
ABC 1ST 100CD'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result