using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?!1ST\b)\d)(?=[^\d\s])|(?<=[^\d\s])(?=(?!1ST\b)\d)";
string substitution = @" ";
string input = @"1ST DEF 100CD
ABC 1ST 100CD";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}