const regex = new RegExp('(?<=(?!1ST\\b)\\d)(?=[^\\d\\s])|(?<=[^\\d\\s])(?=(?!1ST\\b)\\d)', 'gm')
const str = `1ST DEF 100CD
ABC 1ST 100CD`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);