import re
regex = re.compile(r"(?<=(?!1ST\b)\d)(?=[^\d\s])|(?<=[^\d\s])(?=(?!1ST\b)\d)", flags=re.MULTILINE)
test_str = ("1ST DEF 100CD\n"
"ABC 1ST 100CD")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)