package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?([0-9]{1,3}(,[0-9]{3})*(\.[0-9]+)?|\d*\.\d+|\d+)$`)
var str = `123,344.456
1234556
123456.124
-1234
-123,456,789
+1234.67
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}