import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?([0-9]{1,3}(,[0-9]{3})*(\\.[0-9]+)?|\\d*\\.\\d+|\\d+)$";
final String string = "123,344.456\n"
+ "1234556\n"
+ "123456.124\n"
+ "-1234\n"
+ "-123,456,789\n"
+ "+1234.67\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}