const regex = /^[+-]?([0-9]{1,3}(,[0-9]{3})*(\.[0-9]+)?|\d*\.\d+|\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?([0-9]{1,3}(,[0-9]{3})*(\\.[0-9]+)?|\\d*\\.\\d+|\\d+)$', 'gm')
const str = `123,344.456
1234556
123456.124
-1234
-123,456,789
+1234.67
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}