import re
regex = re.compile(r"^[+-]?([0-9]{1,3}(,[0-9]{3})*(\.[0-9]+)?|\d*\.\d+|\d+)$", flags=re.MULTILINE)
test_str = ("123,344.456\n"
"1234556\n"
"123456.124\n"
"-1234\n"
"-123,456,789\n"
"+1234.67\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")